вторник, 10 октября 2017 г.

CCNP Route "Full Scale" Лаба: GRE и VRF-Lite недоVPN


Сегодня быстро закроем тему IGP по IPv4. Рассмотрим две темы, которые стоят как бы особняком - GRE и VRF-Lite.

GRE

Самый простой, пожалуй, метод туннелирования трафика. На один IP заголовок наворачивается ещё один. В Cisco конфигурация GRE предполагает создание туннельного интерфейса. Ему, как и любому другому IP интерфейсу, буду назначены определенные адреса. Нужный трафик просто заворачивается в на эти адреса. Самый просто способ - прописать статический маршрут. Далее по плану переделаем статику на PBR, например.



Выше видна простая конфигурация с двух сторон. В качестве адреса источника будем использовать менеджмент адреса с loopback интерфейсов. Под сам туннель отдадим 172.30.0.0/30.

После такой вот конфигурации уже можно пинговать другую сторону и радоваться.


Теперь можно и нужно настроить клиентов и запихнуть их трафик в туннель. В качестве клиентов у меня PC симулятор, настраивается там все просто. Далее, пропишем самый простой маршрут из всех, которые только можно придумать. По одному на каждый роутер.

R5(config)#ip route 10.123.123.4 255.255.255.252 Tunnel0
O9(config)#ip route 10.123.123.0 255.255.255.252 Tunnel0

После чего клиент возрадуется.


Это практически все, что нужно знать про GRE в рамках CCNP Route.

VRFLite

Ещё меньше нужно знать про VRFLite. Что такое VRF Lite? Это когда мы делаем VPN через сеть с помощью VRFов. Внутри роутеров маршруты клиентов не путаются, потому что находятся в разных инстансах, а между роутерами мы используем сабинтерфейсы. В общем, то ещё извращение. Плюс, надо как-то передавать клиентские маршруты, так что придется ещё и протокол маршрутизации поднимать какой-то на всех этих VRFах.


Конфиг получается довольно внушительных размеров. На каждом роутере создаем VRF, запихиваем в него пару интерфейсов и запускаем в нем OSPF.

R5
ip vrf CUSTOMER1
!
interface Ethernet0/1.10
 encapsulation dot1Q 10
 ip vrf forwarding CUSTOMER1
 ip address 192.168.25.2 255.255.255.252
!
interface Ethernet0/3
 ip vrf forwarding CUSTOMER1
 ip address 10.0.1.1 255.255.255.0
!
router ospf 1 vrf CUSTOMER1
 network 0.0.0.0 255.255.255.255 area 0

E3/R2
ip vrf CUSTOMER1
!
interface Ethernet0/1.10
 encapsulation dot1Q 10
 ip vrf forwarding CUSTOMER1
 ip address 192.168.34.1 255.255.255.252
!
interface Ethernet1/2.10
 encapsulation dot1Q 10
 ip vrf forwarding CUSTOMER1
 ip address 192.168.25.1 255.255.255.252
!
router ospf 1 vrf CUSTOMER1
 network 0.0.0.0 255.255.255.255 area 0


E4/O2
ip vrf CUSTOMER1
!
interface Ethernet0/1.10
 encapsulation dot1Q 10
 ip vrf forwarding CUSTOMER1
 ip address 192.168.34.2 255.255.255.252
!
interface Ethernet1/2.10
 encapsulation dot1Q 10
 ip vrf forwarding CUSTOMER1
 ip address 192.168.47.1 255.255.255.252
!

router ospf 1 vrf CUSTOMER1
 network 0.0.0.0 255.255.255.255 area 0


E7
ip vrf CUSTOMER1
!
interface Ethernet0/0.10
 encapsulation dot1Q 10
 ip vrf forwarding CUSTOMER1
 ip address 192.168.47.2 255.255.255.252
!
interface Ethernet0/3
 ip vrf forwarding CUSTOMER1
 ip address 10.0.2.1 255.255.255.0
!

router ospf 1 vrf CUSTOMER1
 network 0.0.0.0 255.255.255.255 area 0


В итоге, один клиент в сети 10.0.1.100 видит другого в сети 10.0.2.100. Но накладные расходы и ограничения просто неприемлимы.


 Наконец-то!
 5. Advanced IGP routing  (IPv4)
- Configure authentication (plain-text, MD5)
- Configure Summarization
- Metris
- Load balancing (equal, unequal)
- Routing loops
- Advanced redistribution with filtering
- VRF Lite
- GRE Tunneling


 Очень медленно продвигаюсь. Осталось чуть-чуть. )

6. Advanced BGP routing (IPv4)
7. IPv6
8. Management (IPv4/IPv6)
9. Infrastructure

 Ну а все посты в этой бесконечной серии можно посмотреть в этом посте.

Комментариев нет:

Отправить комментарий